Sunday, June 14, 2009

Jaunty and 2.6.30 kernel with Nvidia drivers

I recently upgraded to 2.6.30 on my Jaunty laptop and desktop. Turns out there are some issues with the nvidia drivers that come with Jaunty and the newer 2.6.30 kernel. The following upgrade process worked for me (based on the solution found at
  1. If you have Nvidia drivers then:
    1. Go to some temp directory (~/tmp for me)
    2. wget -c

    3. sudo dpkg -i nvidia-180-kernel-source_180.60-0ubuntu1_i386.deb nvidia-180-libvdpau_180.60-0ubuntu1_i386.deb nvidia-glx-180_180.60-0ubuntu1_i386.deb

  2. wget -c

  3. sudo dpkg -i linux-headers-2.6.30-020630-generic_2.6.30-020630_i386.deb linux-headers-2.6.30-020630_2.6.30-020630_all.deb linux-image-2.6.30-020630-generic_2.6.30-020630_i386.deb


  1. thanks alot solved my problem ;)

  2. Thanks! The drivers are now a later version , but once I changed that it worked like a charm.